Putting a 99 3.0 Vulcan into 01 body with broken 4.0 motor - Ford Ranger Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-09-2017, 11:28 AM Thread Starter
Junior Member
 
Join Date: Apr 2017
Posts: 2
Putting a 99 3.0 Vulcan into 01 body with broken 4.0 motor

Hello again as mentioned in my intro I currently have a 1999 XLT regular cab 3.0 Vulcan Flex Fuel motor. The body has 300k and 20k on the motor, due to my rebuilding the upper end about 2yrs ago with much assistance and guidance from many here. I am currently experiencing a fuel delivery issue with the fuel pump located in the fuel tank.

The basic symptoms are: Fuel pump sometimes staying on and erratic loss of power (sometimes has acceleration then goes into an almost limp mode). I noticed at the beginning of the fall (2016) it not starting like it normal would/should, (as in quick starts after a couple cranks and high rpms until warms a bit) and this too was erratic. Sometimes it would be fine sometimes it wouldn’t stay running unless given more fuel until it warmed. It was suggested perhaps I had gotten some bad gas and decided to try Lucas fuel treatment with the next couple of fill ups (always try to fill tank when refueling, just something I do rather than many stops at the fuel station). It seemed to take the issue of bad cold starting away, yet returned later in the winter.

About a week ago (Spring 2017) I took a 35 mile highway drive to visit my daughter and all was fine on the way there then when I went to go back, it would do as a mentioned previously (see basic symptoms above). I decided to start by checking the number 5 relay (appears to test fine) and then replace the fuel filter on the frame rail.

In doing so noted how rusty every thing is/was (freaking Michigan winters and all the salt) and when attempting to remove the clip from the line to then remove the line from tank I tore the line completely off that side of the filter. It was my intention to drop the tank and clean it if the fuel filter change did not solve the issue.

Well now that I tore the line off the filter I must drop the tank anyway. This I am sure every Ranger owner knows (or may soon know) is quite an operation. After finding out that the fuel pump and assembly would cost in the neighborhood of $400 for the assembly alone, I starting considering my options. I was entertaining the idea of purchasing another newer model Ranger body and swapping my mostly rebuilt 3.0 Vulcan.

I found a 2001 Ranger with 4.0 SOHC 4x4 which currently has a cam chain issue (broken chain). In considering the swap it was mentioned to me by a friend I may have an issue with the computer.

Does anyone have any info to share on swapping my 3.0 into the 2001 4.0 body? I apologize with the length of the post yet wanted to be clear for all and avoid many questions.

Thanks for your time in advance!
ttacco is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Ranger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken all the possible records bahubalig Off Topic 0 08-03-2015 09:28 AM
Lost River Broken Horses rainirodr General Ranger Discussion 0 04-16-2015 03:07 AM
Broken string on shift indicator for AT on 98 Ranger scruffybeast General Ranger Discussion 4 11-01-2011 07:31 PM
broken lift bracket DRKSHADOW Suspension Discussion 9 09-29-2010 04:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome